请选择 进入手机版 | 继续访问电脑版

VirtualBox非官方中文论坛

 找回密码
 立即注册

QQ登录

只需一步,快速开始

搜索
热搜: 活动 交友 discuz
查看: 76|回复: 0

windows 10下使用VirtualBox安装系统黑屏原因

[复制链接]

30

主题

30

帖子

39万

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
390193
发表于 2021-9-1 00:53:38 | 显示全部楼层 |阅读模式
虚拟机程序应用
宿主机系统: Windows hosts » Windows 10
虚拟系统: Linux hosts » Linux All distributions
原因一
win10安装VirtualBox以后系统重启黑屏,无法进入的解决办法:
安全模式或者winPE删除C:\Windows\System32\drivers目录下的 VBoxDrv.sys、VBoxNetAdp.sys、VBoxNetFlt.sys、VBoxUSBMon.sys

为了验证此方法的有效性,我又重新安装了一遍,证明此方法有效
希望能帮上需要的人
来源:https://www.cnblogs.com/tolerance/p/4375605.htm

原因二
bios未开启虚拟化支持

原因三
未关闭Hyper V
参考链接

原因四
需要重置网络,不知道什么原因,我之前有安装VMware,求大神告知。
相关链接

原因五

最近在学习linux,跟着****在Oracle VM VirtualBox安装centos时出现了下图的问题
(图1)
图1中,版本显示的是Red Hat(32-bit)并且在下拉菜单中找不到****中的Red Hat(64-bit)选项。起初以为对后继虚拟电脑的学习影响不大,然而运行时才发现真的会有影响!!
什么影响呢?截图给大家看。见图2
(图2)
图2中,启动新建的虚拟电脑后一直处于黑屏状态,这就很不让人开心了。。
好了,开始寻找解决办法!!
狠狠的百度了一通,发现是新建过程中所选的版本影响的原因(我选的是Red Hat(32 bit),应该选择Red Hat(64 bit))。但是,为什么没有Red Hat(64 bit)这一版本呢?
原因:电脑中的BIOS未开启虚拟化技术(我的是联想win10系统,通过Fn+F1或Fn+F2或。。。的方式开启BIOS都是无效的!)。
Q :win10系统如何开启BIOS的虚拟化技术呢?
A :
     ①步骤一:打开菜单栏中的设置,界面见图3,选择“更新和安全”
         (图3)
    ②步骤二:选择“恢复”——“立即重新启动”,见图4
   ③步骤三:请等待几秒,您将进入图5界面,选择“疑难解答”
(图5)
   ④步骤四:选择“高级选项”,见图6
(图6)
   ⑤步骤五:选择“UEFI固件设置”,见图7
(图7)
   ⑥步骤六:点击“重启”,见图8。然后安安静静的等待BIOS出现在你面前就可以了
(图8)
   ⑦步骤六:BIOS界面如图9,然后将“Intel Virtual Technology”改为"Enabled"后点击“F10”保存即可。
(图9)
—— —— —— —— —— —— —— —— —— —— —— —— —— —— —— —— —— —— —— —— —— —— —— —— —
问题终于解决了!!
在新建一个虚拟电脑看一下,果真“版本”一栏的下拉选项中出现了Red Hat(64 bit)很是开心啊哈哈哈。新建的虚拟电脑后运行了一下,不会黑屏并且可以进行后续操作了,开心到飞起~~
希望这篇博客可以帮助到初入门linux,卡在安装步骤中的同学们,大家加油!!



回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

小黑屋|手机版|Archiver|VirtualBox非官方中文论坛 ( 蜀ICP备16014044号 )

GMT+8, 2021-9-22 06:44 , Processed in 0.046339 second(s), 8 queries , Gzip On, APC On.

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表